I suggest you ...

have a way to ALWAYS default to PRIVATE

I need to have a way to ensure that things are private unless I share them explicitly. It's 2010 and poor privacy is a deal breaker.

92 votes
Vote
Sign in
Signed in as (Sign out)
You have left! (?) (thinking…)
Chris SchoonChris Schoon shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Sandy_diigoSandy_diigo responded  · 

For chrome extension,you can right click on the diigo icon and go to the seeting page to select "private as default while bookmarking’.
It is the same with firefox.
Diigolet doesn’t offer this kind of feature,since it is a simplified version.
As for bulk converting bookmarks to private,
you can choose to view all items in advanced view mode.

13 comments

Sign in
Signed in as (Sign out)
Submitting...
  • davido Tdavido T commented  ·   ·  Flag as inappropriate

    Sandy's response misses the point, I'm afraid. 'Private' should be checked as soon as the extension is installed. Users can 'opt out' of Private by changing their settings, rather than needing to 'opt in' to privacy.

    Here's a common use case: I set up diigo on a new browser. I've done this many times the years--and I usually forget to check that box, for a few weeks at least, even though I know it exists.

  • Ville WalverantaVille Walveranta commented  ·   ·  Flag as inappropriate

    Yes!! Private highlights by default is a must, and it should be selectable separately from the privacy of links (i.e. links could be posted as public by default while highlights would be posted as private by default). There's another suggestion regarding to this here ->> http://feedback.diigo.com/forums/76211-ideas/suggestions/3592147-allow-users-to-have-all-notes-highlights-automatic

  • Dave MackeyDave Mackey commented  ·   ·  Flag as inappropriate

    "private as default while bookmarking" is cool - but really, it isn't my bookmarks I care about, it's my highlights. maybe an option could be added like "private as default while highlighting" - the url could still be shared (unless "private as default while bookmarking" was also selected) but the highlights I made wouldn't be.

  • KK commented  ·   ·  Flag as inappropriate

    Sandy: It seems not to work that way on pictures and captures.

  • mellowongs xmellowongs x commented  ·   ·  Flag as inappropriate

    I have just discovered Diigo.. I can't believe that Private can't be set on by default! that's a deal breaker for me!!

  • David ReesDavid Rees commented  ·   ·  Flag as inappropriate

    Hi Sandy,
    I did that and it was still not marking them private. Today it seems to be working so perhaps it needs a restart of Firefox. Or it could have to do with me working in multiple windows, I've noticed Diigo doesn't seem to really keep cross-window state (e.g. if I log into one Firefox window I still have to log into another window also).

  • David ReesDavid Rees commented  ·   ·  Flag as inappropriate

    Even with "private with bookmarking" turned on, when highlighting it adds them to my library without making them private. The fact that just highlighting something causes it to be shared is pretty scary.

  • Tim BatchelderTim Batchelder commented  ·   ·  Flag as inappropriate

    I agree. I have requested this a number of times from Diigo and have not even received a response. Also, it would be helpful to help many users correct this issue to add a function to change the status of bookmarks from public to private in bulk. I do not believe Diigo understands the importance of privacy.

  • Ezqimo .Ezqimo . commented  ·   ·  Flag as inappropriate

    Ref. my comment in that other thread:

    "Great that this got fixed, but there is one flaw left: Even if it remembers my desired default, then every time I have made an exeption and removed he private checkmark when bookmarking something, then the next time I bookmark something, the default has changed to public, so every time I want to make something public, I must remember to set the default back to private..."

  • Ezqimo .Ezqimo . commented  ·   ·  Flag as inappropriate

    This does not work well in the current Chrome and Opera diigolet scripts, but it is working in the Firefox Diigo extension (it remembers the default privacy setting that you can set in the toolbar options.). I agree it is important to fix this.

Feedback and Knowledge Base